Give Lively is experiencing outages.

Incident Report for Give Lively

Resolved

Our engineers have confirmed the platform is performing as expected and the service interruption has been resolved. Thank you so much for your patience.
Posted Aug 25, 2026 - 16:28 EDT

Monitoring

The platform is now back up and our engineering team is monitoring the fix as we continue to stabilize. We appreciate your patience.
Posted Aug 25, 2026 - 13:23 EDT

Investigating

We are currently seeing service interruptions on both our admin portal pages and donation pages. Our engineering team is actively investigating and we will update here as soon as we learn more.
Posted Aug 25, 2026 - 13:17 EDT
This incident affected: Give Lively (Give Lively portals and donation pages).