Our engineers have deployed a fix for the issue preventing the Payment Form on our Event Ticketing pages and Widgets from loading. Thank you for your patience.
Posted Mar 26, 2026 - 17:37 EDT
Update
We are continuing to investigate this issue. We appreciate your patience.
Posted Mar 26, 2026 - 16:08 EDT
Investigating
Our engineers have identified an issue with our payment form loading slowly or failing to load on Event Ticketing pages. We are investigating and will continue to update as we discover more information.
Posted Mar 26, 2026 - 15:26 EDT
This incident affected: Give Lively (Give Lively portals and donation pages).