Reports of issues affecting our platform

Incident Report for Give Lively

Resolved

This incident has been resolved. All pages and services are functioning normally again. Thank you for your patience and understanding.

To receive future notifications by email or Slack whenever Give Lively creates, updates, or resolves an incident, click “Subscribe to Updates” on https://status.givelively.org.
Posted Apr 03, 2026 - 15:16 EDT

Monitoring

Fixes have been implemented, and we are monitoring the issue to ensure that it is fully resolved. We will share more information should follow-up steps be required. If you have not already subscribed, click “Subscribe to Updates” to be notified right away via email. Thank you for your patience and understanding.
Posted Apr 03, 2026 - 13:45 EDT

Identified

As of 1:10PM EST, we have identified the root issue affecting some of our pages and are working on implementing a fix.

If you have not already subscribed, click “Subscribe to Updates” to be notified right away via email.

We deeply apologize for any inconvenience.
Posted Apr 03, 2026 - 13:29 EDT

Investigating

As of 12:03pm EST on April 3rd, we are noticing a degradation of service on some of our pages, and we are currently investigating.

Please stand by for more information about the impacted components (see below).

If you have not already subscribed, click “Subscribe to Updates” to be notified right away via email.

We deeply apologize for any inconvenience.
Posted Apr 03, 2026 - 12:15 EDT
This incident affected: Give Lively (Give Lively portals and donation pages, Give Lively servers, impacting donation pages, portals and databases).