Reports of issues affecting our platform

Incident Report for Give Lively

Resolved

This incident has been resolved. All pages and services are functioning normally again. The total degraded service time was around three hours. Thank you for your patience and understanding.

To receive future notifications by email or Slack whenever Give Lively creates, updates, or resolves an incident, click “Subscribe to Updates” on https://status.givelively.org.
Posted Mar 03, 2026 - 19:40 EST

Monitoring

With a fix in place, we are committed to ensuring that the issue is fully resolved. We are continuing to monitor our platform for smooth operations as some services are still degraded. We will share more information should follow-up steps be required. If you have not already subscribed, click “Subscribe to Updates” to be notified right away via email. Thank you for your patience and understanding.
Posted Mar 03, 2026 - 19:02 EST

Investigating

As of 6:18 pm on Tuesday, March 3rd, we are investigating reports of issues affecting our platform.

Please stand by for more information about the impacted components (see below).

If you have not already subscribed, click “Subscribe to Updates” to be notified right away via email.

We deeply apologize for any inconvenience.
Posted Mar 03, 2026 - 18:37 EST
This incident affected: Give Lively (Give Lively portals and donation pages, Give Lively servers, impacting donation pages, portals and databases).